Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

Bug in setOfflineAlert ? #3597

benprim ·
Dear all,

I'm trying to switch OfflineAlert off before terminating a cloud node

I tried this :

groovy:
import com.pmease.quickbuild.entitymanager.TokenManager;
def nodeToken = TokenManager.instance.getByValue(node.getToken());
nodeToken.setOfflineAlert(false);


but it doesn't look like the flag is updated (OfflineAlert stays true).
Is it a bug ? or am I missing something here ?
thanks !
Ben
  • replies 1
  • views 2802
  • stars 0
benprim ·
After some more digging, I found the solution by myself.
If someone needs the solution : you need to go through CacheManager (and execute the script on the server )

groovy:
import com.pmease.quickbuild.CacheManager;
def t_master = CacheManager.instance.getToken("someip",someport);
t_master.setOfflineAlert(false);