Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

MSBuild step hanging with QB Logging #2599

dlregis ·
QB Version 5.07

MSBuild is being invoked and ends up hanging the step. This is the command-line that QB is invoking:

14:18:35,018 DEBUG - Executing command: C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe /nologo /noconsolelogger /l:QBLogger,D:\qb_installer\framework\configuration\org.eclipse.osgi\com\pmease\quickbuild\plugin\builder\msbuild\PMEase.QuickBuild.MSBuild.Logger.dll;v=detailed /p:IIF_ProductVersion=10.0.0 D:\qb\workspacePath\Product.proj


The log output looks normal until it starts displaying the following:

14:18:37,083 INFO - QB_LOGEVENT:MESSAGE_RAISED:Normal


It displays 140 of these lines in less than a second then hangs. If I invoke the exact command-line that QB is using in a command-window, it hangs in the same manner and the command-window has to be closed.

If I alter the command-line to omit the QB logger, the MSBuild command executes normally and takes only 2-3 seconds.
  • replies 7
  • views 2667
  • stars 0
steveluo ADMIN ·
Hi,

I cannot reproduce this error. Is this error occurred for all your msbuild project or just for this project?
dlregis ·
The problem seems to be particular to this project ... other uses of the MSBuild step work fine.
steveluo ADMIN ·
Please send me (Steve at pmease dot com) the console log both with QB logger and without QB logger.
dlregis ·
Sorry for the delayed response -- I've been out of the office for a week.

I've sent an email as requested with the logfiles attached. Please let me know if you need additional information.
kring789 ·
Was there a resolution to this? We're having the same problem.

Thanks,
Kevin
steveluo ADMIN ·
Hi, sorry, we haven't found the resolution, yet. The issue has been filed below:

http://track.pmease.com/browse/QB-1876

It is related to MSBuild Wix candle target, so if you don't use Wix, please send me your build log, it would be better to turn your configuration log level to debug or trace and rebuild the configuration.
kring789 ·
Yes, it's happening during Wix / candle for me as well.

Thanks,
Kevin