Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

Which QB version will support JDK 1.5 version #4008

Sharan ·

Hi Team, We are planning to upgrade our QB server from 2.1 to some higher version. We are using Java 1.5 version in our project. I have seen that QB8.0 supports JDK 1.7 and above. Could you please let me know which version of Quick Build will be supported by JDK 1.5

  • replies 2
  • views 42
  • stars 1
robinshen ADMIN ·
steveluo ADMIN ·

@Sharan If your OS platform supports the latest JDK, you may consider to use different Java version for running QuickBuild or building your projects, so, you can use the latest QuickBuild version.

Running QuickBuild

QuickBuild can be started with a specified Java version by adding/changing below line in ${quickbuild.home}/conf/wrapper.conf

wrapper.java.command=%java_home%/bin/java

here java_home is your JDK path. More details can be found in below page:

Building your projects

Building your projects with a specified Java version depends on your build tools. For example, if your project is using Maven, you can set a specific Java version to Maven.