Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

Incorrect Build and Log Timestamp Fixed #4043

jmuirhead ·

I've had this problem a couple of times in the past 2 - 3 years. Using a given browser (usually Chrome because that's what most folks use), a given user will see the QuickBuild build and build log timestamps with an incorrect time. Normally an hour or two ahead or behind the correct local time. All other users, and all other browsers (e.g. Firefox, IE, Safari), have the correct local time.

The problem (I can't take credit for this, one of my colleagues figured it out) is the QuickBuild cookies. There are two cookies that must be deleted: QuickBuildBrowserTime and JSESSIONID. The QuickBuildBrowserTime cookie sometimes has the incorrect time zone. Even though the JSESSIONID cookie is supposed to expire when the QB session ends, sometimes it will persist.

I'm not sure if the incorrect time zone is caused by daylight savings time not being correctly recognized, or if it is caused by the user connecting to QB from a different time zone when traveling. I have not been able to nail this down yet. Whatever the case may be, while running the browser showing the issue: logging out of QB, deleting the two cookies mentioned above, then logging back into QB corrected the problem.

  • replies 3
  • views 18
  • stars 0
robinshen ADMIN ·

The QuickBuildBrowserTime cookie is used to detect user browser timezone and it will be updated every time user restarts the session (closes browser and revisits QB). When the issue happens next time, please restart the browser and check value of this cookie again.

jmuirhead ·

Hi Robin:

Restarting the browser is one of the first things we did. In fact, on the 'failing' systems, both the session and the QuickBuildBrowerTime cookies persisted. In other words, they were both present even though the browser had not even been re-opened. We even restarted the PC. Same result. Deleting both cookies was the only thing we found that solved the issue.

robinshen ADMIN ·

The cookie may persist, but the value should be updated after restarting the session. When it happens next time, please record the value of QuickBuildBrowserTime, then close all Chrome browsers and open again to point to QB, and then record the value again.