Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

Unexpected Exception #4453

MFalkner ·

Working at home, I've got a slower connection to the QuickBuild server.
Often, I have issues with the content (see below).
Is this a known issue and is there anything I can do?

  1. Wrong content in gadget:
    On the dashboard, some gadgets, show no data and/or gadget 1 shows data from gadget 2.
    Usually, pressing F5 will show different data, but mostly still not correct.

  2. Wrong task triggered:
    I start build A but build B is started.
    I want to edit node 1, but node 3 is opened.
    Usually, I have to go back and try to start again.

  3. Opening the logs of a step shows "unexpected exception"
    Usually, pressing F5 will show the content.

Whoops! An unexpected exception occurred.
Error Details:

Message: null

Root cause:

at com.pmease.quickbuild.plugin.scm.perforce.ShelvedChangesBuildTabContribution.getTabs(
at org.apache.wicket.Component.fireInitialize(
at org.apache.wicket.MarkupContainer.internalInitialize(
at org.apache.wicket.Page.internalPrepareForRender(
at org.apache.wicket.Component.render(
at org.apache.wicket.Page.renderPage(
at org.apache.wicket.request.handler.render.WebPageRenderer.renderPage(
at org.apache.wicket.request.handler.render.WebPageRenderer.respond(
at org.apache.wicket.request.handler.RenderPageRequestHandler.respond(
at org.apache.wicket.request.cycle.RequestCycle$HandlerExecutor.respond(
at org.apache.wicket.request.RequestHandlerStack.execute(
at org.apache.wicket.request.cycle.RequestCycle.processRequest(
at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(
at org.apache.wicket.protocol.http.WicketFilter.processRequest(
at org.apache.wicket.protocol.http.WicketServlet.doGet(
at javax.servlet.http.HttpServlet.service(
at com.pmease.quickbuild.web.MainServlet.service(
at javax.servlet.http.HttpServlet.service(
at org.eclipse.equinox.http.helper.FilterServletAdaptor$FilterChainImpl.doFilter(
at org.eclipse.jetty.servlets.GzipFilter.doFilter(
at org.eclipse.equinox.http.helper.FilterServletAdaptor.service(
at org.eclipse.jetty.servlet.ServletHolder.handle(
at org.eclipse.jetty.servlet.ServletHandler$ChainEnd.doFilter(
at com.pmease.quickbuild.Quickbuild$DisableTraceFilter.doFilter(
at org.eclipse.jetty.servlet.FilterHolder.doFilter(
at org.eclipse.jetty.servlet.ServletHandler$Chain.doFilter(
at org.eclipse.jetty.servlet.ServletHandler.doHandle(
at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(
at org.eclipse.jetty.server.session.SessionHandler.doHandle(
at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(
at org.eclipse.jetty.server.handler.ContextHandler.doHandle(
at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(
at org.eclipse.jetty.servlet.ServletHandler.doScope(
at org.eclipse.jetty.server.session.SessionHandler.doScope(
at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(
at org.eclipse.jetty.server.handler.ContextHandler.doScope(
at org.eclipse.jetty.server.handler.ScopedHandler.handle(
at org.eclipse.jetty.server.handler.HandlerCollection.handle(
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
at org.eclipse.jetty.server.Server.handle(
at org.eclipse.jetty.server.HttpChannel.lambda$handle$1(
at org.eclipse.jetty.server.HttpChannel.dispatch(
at org.eclipse.jetty.server.HttpChannel.handle(
at org.eclipse.jetty.server.HttpConnection.onFillable(
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(
at org.eclipse.jetty.util.thread.ReservedThreadExecutor$
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
at org.eclipse.jetty.util.thread.QueuedThreadPool$
at Source)

  • solved #5
  • replies 9
  • views 243
  • stars 0
robinshen ADMIN ·

This looks very abnormal to me, and should not caused by slow connections. Are you accessing QB via a proxy? If so, is it possible to access QB 8810 port directly to see if the problem still exist?

MFalkner ·

I'm logged in to the company via VPN tunnel and they have got a proxy to access all external pages. However, QB should be internal and therefore bypass the proxy.

I'm using to access QB, so directly 8810 already.

Could the VPN tunnel be the problem?

robinshen ADMIN ·

Not sure if it is caused by VPN. Have you ever encounter this without using VPN?

robinshen ADMIN ·
MFalkner ·

At a first glance, it looks it really makes a difference. Many thanks for the hint.
I'll have to monitor it for a while.
Also, so far, I did not manage to download the self-signed certificate to my computer yet, but will probably find out how to do this in a quite hour.

MFalkner ·

Ok, this is how to export the public cert, might be worth adding to the wiki page:
/path/to/jdk/bin/keytool -export -alias QuickBuild -keystore /path/to/keystore -rfc -file qb-public.cert

robinshen ADMIN ·

There is a section in the SSL wiki page explaining how to import certificate into QB's keystore.

MFalkner ·

Sure, that is what I did, and I would not have been able to do it without the instructions.
What I did not find is, how to export the self-signed certificate to use it in the browser to avoid this annoying security message when accessing QB.

Anyway, so far one day of use and no odd behavior anymore, looks like this was the solution.
Many thanks.

robinshen ADMIN ·

I see. I'd suggest to use certificate with trusted CA to avoid browser security alerts, for instance let's encrypt. That is what our own QB instance ( is using.