Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

QuickBuild is mis-gendering my macos box. #4457

drdt ·

I have two Mac OSX boxes showing incorrectly in the QB agent list. Here is their info from the operating system:

macbuild@osx11rel1-1:~ $ uname -a
Darwin 20.3.0 Darwin Kernel Version 20.3.0: Thu Jan 21 00:07:06 PST 2021; root:xnu-7195.81.3~1/RELEASE_X86_64 x86_64

macbuild@osx11arm64rel2-1:~ $ uname -a
Darwin 20.3.0 Darwin Kernel Version 20.3.0: Thu Jan 21 00:06:51 PST 2021; root:xnu-7195.81.3~1/RELEASE_ARM64_T8101 arm64

However, in the QB agent grid, both of these machines show up as:

os.arch: x86_64 Mac OS X
os.version: 10.16

QB seems not to recognize v11 of MacOS, nor the arm64 (aka 'm1') architecture. Can you look into it? I am on QuickBuild v12.0.10. I tried removing and reinstalling the agents but the information did not change.

  • replies 3
  • views 681
  • stars 0
steveluo ADMIN ·


Do you find these from system attributes table? Those params are reported from JDK and is a bug from JDK, see discussions below:

and bug report below:

it seems that the bug is fixed in JDK 18.

drdt ·

My workaround was to create user attributes on the afflicted agent to override the values of os.version and os.arch to match the output of "uname -a". The user attributes are picked up by the resource definition logic in the build grid and node selection logic in build steps. For example:

  • [All agents with specified attribute value] "os.arch" [equals] "arm64".

I have a job that runs whenever a new agent connects to the server to update this and other attributes used in node selection.

drdt ·

Just wanted to follow up to say, we encountered this same issue on Windows 2022. Upgrading to Java 17 solved it.