Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

Cobertura report and missing files from repository #53

HugoDescamps ·

Hi,
I’m contacting you because we have a code coverage process in our project, and we would like to correctly display its generated Cobertura report on our QuickBuild configuration.
The issue is that QuickBuild cannot access any file specified in the report, while there is no problem when reading the it locally.
Files path are reconstructed using the classic Cobertura field and filename property for each class:

<source>D:</source>
<class name="MyImpl.cpp" filename="Project\ Features\Client\Private\MyImpl.cpp" line-rate="0.23076923076923078" branch-rate="0" complexity="0">

This file configuration correctly opens D:\Project\Features\Client\Private\MyImpl.cpp file with code coverage annotation when read locally.
However, when read from QuickBuild Cobertura report tab, file “cannot be found in repository”:
screenshot_censored.jpg

We tried editing the report file before uploading it:

Sans titre_censored.jpg

Are we missing something here? Misunderstanding what ‘repository’ means in this error ?
Thanks.

  • replies 1
  • views 578
  • stars 0
robinshen ADMIN ·

What is your QB version? Also please navigate to workspace tab of the configuration, and select the node running cobertura coverage, QB should show path to the workspace directory. What is the value there?