Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

No data version found in database. #85

melvinuy117 ·

Hello everyone, I'm fairly new to quickbuild and I've been tasked to upgrade it, I followed the steps in the upgrade guide from QB 8.0x to QB 13.0x. What happened was when I'm upgrading the QB server, it suddenly stopped in the middle of process and found out that the disk is full. When I tried to upgrade it again after freeing up the space, the error No data version found in database shows, even I try to restore the back up, same error appears. Does anyone encountered this error?

2023-05-18 07:07:20,251 ERROR >>> Exception in thread "main" com.pmease.quickbuild.QuickbuildException: No data version found in database.
2023-05-18 07:07:20,251 ERROR >>> at com.pmease.quickbuild.util.DbUtils.getDataVersion(
2023-05-18 07:07:20,252 ERROR >>> at com.pmease.quickbuild.Quickbuild.getVersion(
2023-05-18 07:07:20,252 ERROR >>> at com.pmease.quickbuild.bootstrap.Bootstrap$2.execute(
2023-05-18 07:07:20,252 ERROR >>> at com.pmease.quickbuild.Quickbuild$
2023-05-18 07:07:20,252 ERROR >>> at
2023-05-18 07:07:20,594 ERROR Unable to upgrade specified installation due to above error

  • solved #3
  • replies 1
  • views 908
  • stars 0
robinshen ADMIN ·

In this case, you will need to first delete and create the database, restore QB8 database from backup and go through the upgrade procedure again.